SB-Pro SB 16 Clone - Creative Treiber ?

DOS-Konfiguration, Anwendungen, Treiber und TSRs
Benutzeravatar
MSDOS622
Kommandozeilenfetischist
Beiträge: 152
Registriert: Sa 1. Mär 2014, 20:15

SB-Pro SB 16 Clone - Creative Treiber ?

Beitragvon MSDOS622 » Mi 19. Mär 2014, 23:13

Mein Toshiba hat nicht wie angenommen einen SB16 Clone drin (obwohl google das oftmals so angibt) sonder einen SB Pro Clone, mt OPL Sax2 Chip.

Es reicht unter DOS vollkomen aus die SET BLASTER Variablen zu setzen.

Aber auch der OPL3Sax2 CD-Rom.sys Treiber sorgt für dieslebe Soundqualität unter DOS...


Jetzt habe ich sämtliche Varianten der original SB 16 / SB Pro Treiber (DOS) vom fpoli ftp Server gezogen und frage mich, ob das einbinden in config.sys Sinn macht ?

Oder "erkennt" der Treiber sofort das da etwas "nicht vorhanden" ist ?

Ich weiss, probieren geht über studieren, aber ich gehe jetzt schlafen. :)
S+M
DOS-Guru
Beiträge: 832
Registriert: Mo 10. Jun 2013, 17:04
Wohnort: BW

Re: SB-Pro SB 16 Clone - Creative Treiber ?

Beitragvon S+M » Do 20. Mär 2014, 21:11

Bei den alten non-PnP-Karten sorgt die Installation hauptsächlich für einen Mixer, ein Demo-Programm und vielleicht noch einen CD-Rom-Treiber, einen Soundtreiber gibt es nicht (bringen die Spiele selbst mit).

Aber:
- Den Mixer kannst du natürlich nur mit einer orginalen Sb16 benutzen, deswegen solltest du für deine Karte den passenden Yamaha-Treiber benutzen!
- Das Demoprogramm bringt nichts...
- Der CD-Rom Treiber wird auf einer Karte natürlich auch nicht funktionieren.

Creative-Treiber geben (abgesehen für Creative-Karten selbst) eigentlich nur Sinn, um in win3.11 Sound zu bekommen, falls der Hersteller keinen Treiber liefert (aber da nur den win3.11 Treiber benutzen und nichts unter DOS!), die Nachteile sind quasi immer ein nicht funktionierender Mixer.

€dit: Der Yamaha-Chip unterstützt meines Wissens nach auch nur SB-Pro, von daher solltest du von SB16 sowieso die Finger lassen, aber wie gesagt bringt dir ein Creative-Dos-Treiber überhaupt nichts, nutze den passenden vom Hersteller!
Benutzeravatar
MSDOS622
Kommandozeilenfetischist
Beiträge: 152
Registriert: Sa 1. Mär 2014, 20:15

Re: SB-Pro SB 16 Clone - Creative Treiber ?

Beitragvon MSDOS622 » Do 20. Mär 2014, 22:18

Ich habe ja den Laptop p133MHz Toshiba Satellite 220CS mit OPLSAx3 OnBoard Chip.
Die meisten Seiten im Netz sagen das es ein SB16 Clone ist. Im BiOS ist aber WSS als auch SBPro aufgeführt.

Bei den SBPro / SB 16 Karten ist ja nicht nur der Mixer sondern auch folgendes immer dabei gewesen :

1) AUXDRV.DRV - Auxiliary driver for Mixer Control under DOS
2) CT-VOICE.DRV - Memory-mode voice driver
3) CTVDSK.DRV - Disk double-buffering voice driver
4) CTWDSK.DRV - Disk double-buffering wave driver
5) CTWMEM.DRV - Memory-mode wave driver
6) ORGAN.DRV - FM Organ driver

Ich weiss das die damals bei meiner SB Pro alle geladen/genutzt wurden und das trotzdem SET BLASTER gesetzt war.

Das merkwürdige ist ja bei mir, das SET BLASTER für Sound sorgt, aber auch NUR der OPL3-CD-Rom.sys Treiber OHNE SET BLASTER gibt digital und midi (adlib) aus. (für mich ist das jedenfalls merkwürdig) ^^

Mir gehts es darum, z.B. den Creative Voice Editor nutzen zu können, der friert nämlich ein.
Oder die "Creative Multimedia Demo"...friert auch ein.

Ich habe jetzt schon ein paar Spiele, die bei der "Autoerkennung vom Sound" SB16/AWE32 erkennen (wollen).
Läuft dann auch ohne Probleme.

Ich kann leider erst am Wochenende selbst testen und werde dann Bericht erstatten. Vorher hätte ich nur gerne alle möglichen Informationen eingeholt. Villeicht macht es ja wirklich keinen Sinn. o_O

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste