486DX33 Gehäuseverkabelung und Festplattengröße

Auswahl, Einrichtung und Betrieb von Rechnern und Komponenten
Benutzeravatar
Thomas
CONFIG.SYS-Autor
Beiträge: 297
Registriert: Mi 22. Jun 2016, 12:29
Wohnort: Nähe von Limburg / Lahn
Kontaktdaten:

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Thomas » Mo 18. Mär 2019, 17:33

Nene, Dosenware. nicht als Primärer. Nur als sekundärer. Ich denke das liegt daran dass ich die Aztech nur auf IRQ 15 (auch auf 10 und 11 aber da wird gar nichts erkannt) jumpern kann. Ich denke im Bios ist irgendwo gecodet dass IRQ 14 dem ersten und 15 dem zweiten IDE Port entsprechen MUSS! So eine Art "Quasi-Standard".

Und naturlich hast Du auch zum Teil recht! Wenn ich onboard IDE habe, sind die, meines Wissens nach fest, auf IRQ 14, 15.
Wenn ich jetzt eine IDE Karte her nehme und ihre Jumpers, bzw. Software settings es zu lassen sie auf andere IRQs zu setzen, gewinne ich 1-2 IDE Kanäle DAZU! Sollte sie wie auch meine Soundkarte, nur IRQ 14 oder 15 (wie einige ältere multi I/O Karten) zulassen, gibt es natürlich Konflikte. Wenn man dann aber den Onboard deaktiviert, so läuft alles allein über die Karte. Die Soundkarten IDE Ports wurden ja extra eingeführt, weil in der 386/486 Ära viele oder gar die meisten Controller nur einen IDE Kanal hatten auf IRQ14 und viele User wohl zwei HDDs nutzten wegen dem damals kleinen Speicherplatz.
So musste man nicht noch eine teure ISA Karte kaufen und konfigurieren. Das würde auch erklären warum ich die Soundkarte nicht auf IDE 14 jumpern kann!
Ein bisschen DOS kann oft mehr als ein Haufen Fenster.

Gigabyte GA-586HX, P54C 100@75MHz, 24MB RAM, AVGA3-22-1M ISA, RTL8029AS PCI, Goldstar Prime 2 ISA, MA5ASOUND, Dreambl. X2 DB, HD 4x2GB, 48x CD, 3,5" Floppy, 2xRS232, 1xPar., PS/2 Maus
Benutzeravatar
Thomas
CONFIG.SYS-Autor
Beiträge: 297
Registriert: Mi 22. Jun 2016, 12:29
Wohnort: Nähe von Limburg / Lahn
Kontaktdaten:

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Thomas » Mo 18. Mär 2019, 17:39

Dosenware hat geschrieben:Die Multi IO Karten lassen sich üblicherweise auch als Primärer IDE-Port Jumpern.


Ja, na klar! Das hast du dann missverstanden. Für mich kam Dein Statement so rüber als könne ein Soundkarten IDE Port, der ja nichts anderes ist als ein Teil eines Multi I/O Controllers, nicht gebootet werden ohne dedizierte BIOS unterstützung. Auf dem ISA Bus ist das aber schon seit Beginn der ersten Festplatten möglich und diese Implementierung gibt es bis heute. Secondary IDE disabled, Soundkarte rein, Secondary IDE wieder da.

Und die I/O Karten liessen sich in der Regel auf beides jumpern, da man ja evtl. später mal eine dazu stecken wollte.

Eine wirklich angenehme Diskussion, macht Spaß. :-)
Ein bisschen DOS kann oft mehr als ein Haufen Fenster.

Gigabyte GA-586HX, P54C 100@75MHz, 24MB RAM, AVGA3-22-1M ISA, RTL8029AS PCI, Goldstar Prime 2 ISA, MA5ASOUND, Dreambl. X2 DB, HD 4x2GB, 48x CD, 3,5" Floppy, 2xRS232, 1xPar., PS/2 Maus
Oliver1980
Solitärspieler
Beiträge: 21
Registriert: Di 12. Feb 2019, 18:06

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Oliver1980 » Mo 18. Mär 2019, 18:33

@Thomas & Dosenware

Es ist wirklich ein Ide Kabel 40pin. Die 5 Abgriffe sind wirklich nur für verschiedene Abstände gedacht. Mehr als ein Master und ein Slave geht auch hier nicht. Mit dem Belegen der beiden Enden meinst du das Ende für die Controllerkarte und den letzten Slave Abgriff, oder?

Interessant... Hab mich schon gefragt warum da ein Ide Anschluss auf meiner Soundkarte ist... Das man an einer Soundkarte beispielsweise nen Cdrom anschließen kann hätt ich nicht gedacht. Dann hätt ich mir das längere Kabel wohl auch sparen können :???: . Naja zu süpät 8-). Aber ausprobieren werd ich das nochmal wann...
Oliver1980
Solitärspieler
Beiträge: 21
Registriert: Di 12. Feb 2019, 18:06

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Oliver1980 » Mo 18. Mär 2019, 18:39

Ich hab meine Soundkarte noch nicht in Betrieb genommen. Also noch keine Treiber gesucht und installiert... Erstmal warte ich jetzt noch auf mein Diskettenlaufwerk bevor ich die Kiste wieder anschmeiße 8-). Aber theoretisch könnte ich die Soundkarte als solche nutzen und gleichzeitig eine CdRom daran betreiben...? Versteh ich das richtig?
Dateianhänge
Soundkarte1.jpg
Soundkarte1.jpg (183.52 KiB) 457 mal betrachtet
Benutzeravatar
Thomas
CONFIG.SYS-Autor
Beiträge: 297
Registriert: Mi 22. Jun 2016, 12:29
Wohnort: Nähe von Limburg / Lahn
Kontaktdaten:

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Thomas » Mo 18. Mär 2019, 19:21

Mit dem Belegen der beiden Enden meinst du das Ende für die Controllerkarte und den letzten Slave Abgriff, oder?


Das würde mich auch interessieren... Ich denke aber er meint es genau so. Nur warum soll man das machen? Ich hatte schon oft lange IDE Kabel für eine Festplatte und dann das kurze Ende benützt.

Eigentlich ist der weiteste Abgriff der Master, bzw. bei zwei Laufwerken das was weiter vom Controller angeschlossen wird. Aber ich glaube das greift nur wenn beide LWs auf Cable Select (Grob gesprochen: Automatische Ma/Sl zuweisung)
Es ist halt so im Standard definiert. Aber das habe ich nur ganz selten so gehalten. Ich hatte wirklich NIE Probleme mit der ersten HDD auf Ma gejumpert und dem zweiten CD-ROM auf Sl gejumpert.

Ja, es gab viele Soundkarten mit CD-ROM Anschluss. Zuerst proprietäre wie Mitsumi, Panasonic und Sony, bzw. deren Klone (in Lizenz) Aztech, Creative etc. Bis auf Sony haben die auch einen 40Pin Connector wie IDE, also nicht verwechseln.
Deine Soundkarte hat leider nur letztere wenn ich das auf dem Bild richtig erkenne. CD/S für Sony, CD/M für Mitsumi und CD/P für Panasonic. Also bitte kein IDE CD-ROM daran anschliessen.
Hast Du denn mehr als eine Festplatte für den 486er? Ansonsten einfach das CD als Slave mit an das Kabel der Platte.

Edit: hatte jetzt ein ähnliches Phänomen. Ich habe noch eine 8GB Samsung Platte gefunden und wollte die per chs ansteuern. Im BIOS 16383/16/63 eingestellt, wurde korrekt erkannt. Fdisk sieht nur 504MB
Umgestellt auf lba, Daten im BIOS richtig, bei der Auflistung kurz vorm booten, 520MB. Danach im BIOS ebenfalls nur 520MB
Erst ein BIOS LowLevel Format auf lba klappte dann.
Ein bisschen DOS kann oft mehr als ein Haufen Fenster.

Gigabyte GA-586HX, P54C 100@75MHz, 24MB RAM, AVGA3-22-1M ISA, RTL8029AS PCI, Goldstar Prime 2 ISA, MA5ASOUND, Dreambl. X2 DB, HD 4x2GB, 48x CD, 3,5" Floppy, 2xRS232, 1xPar., PS/2 Maus
Disruptor
HELP.COM-Benutzer
Beiträge: 45
Registriert: Do 2. Nov 2017, 12:59

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Disruptor » Di 26. Mär 2019, 19:38

Thomas hat geschrieben:Das ist so richtig. Damals war noch nicht so viel mit "erkennen".
Mein erstes CD-Rom war ein 2x Mitsumi Mit AT-Bus Controller Karte. Das zweite war dann ein Mitsumi 4x IDE. Da mußte ich mir extra ne Isa IDE Karte dazu kaufen weil die Controller Karte die bei meinem 486er dabei war das CD-ROM nicht "wollte". Nochmal ohne davon booten zu wollen mit dem Treiber. Wurde einfach nicht gefunden. Mit der neuen Karte ging es dann.
Ich hatte aber damals auch noch nicht so die Ahnung. Kann sein dass der Treiber nur auf 170h und IRQ 15 gesucht hatte. So war auch die gekaufte Karte gejumpert. Ich meine fest. Und die vom PC umzujumpern bin ich doch seiner Zeit nie auf die Idee gekommen. :shock:


Das mit dem proprietären Mitsumi-Controller war so:
Erstes Laufwerk: Mitsumi LU005S (Single Speed, legendär mit Klappe!) (und ich Honk hab die vor 15 Jahren zum Schrott gegeben!)
Zweites Laufwerk: Mitsumi FX-001D (Double Speed, mit Tray/Schublade)
Das LU005S funktionierte auch am Controller des FX-001D, aber nicht umgekehrt!
Danach kamen nur noch Laufwerke mit Tray/Schublade, allesamt am IDE/AT-BUS Controller, wo auch Festplatten angeschlssen waren.

Also hatten FX-001D und Quad Speed / höher einen grundverschiedenen Controller, jedoch den gleichen Kabeltyp!

Wahrscheinlich hattest du ein Master-Slave-Problem bei deinem 486er... dass dein alter proprietärer Mitsumi-Controller mit dem IDE/AT-Bus-Quadspeed nicht wollte wundert mich nicht.
Benutzeravatar
Thomas
CONFIG.SYS-Autor
Beiträge: 297
Registriert: Mi 22. Jun 2016, 12:29
Wohnort: Nähe von Limburg / Lahn
Kontaktdaten:

Re: 486DX33 Gehäuseverkabelung und Festplattengröße

Beitragvon Thomas » Di 26. Mär 2019, 22:02

Disruptor hat geschrieben:Wahrscheinlich hattest du ein Master-Slave-Problem bei deinem 486er...


Wahrscheinlich hatte ich das nicht. Das Master/Slave Prinzip hatte ich durchaus verstanden.

Disruptor hat geschrieben:dass dein alter proprietärer Mitsumi-Controller mit dem IDE/AT-Bus-Quadspeed nicht wollte wundert mich nicht.


Wundert mich auch nicht. Das habe ich weder versucht, noch behauptet. Ich schrieb dass mein Mitsumi IDE nicht am Controller (Goldstar Prime 2c) des PC wollte.
OK, ich habe nicht geschrieben dass ich HDD=Master und CDR=Slave und andersherum probierte.
Der Goldstar war damals primär gejumpert, Also 1F0h und IRQ 14. Daher vermute ich dass der Mitsumi Treiber nur auf sekundär 170h und IRQ 15 nach Laufwerken gesucht hat. Jedenfalls ohne zusätzliche Parameter anzugeben.
Ein bisschen DOS kann oft mehr als ein Haufen Fenster.

Gigabyte GA-586HX, P54C 100@75MHz, 24MB RAM, AVGA3-22-1M ISA, RTL8029AS PCI, Goldstar Prime 2 ISA, MA5ASOUND, Dreambl. X2 DB, HD 4x2GB, 48x CD, 3,5" Floppy, 2xRS232, 1xPar., PS/2 Maus

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste